Home

Cardbox Talk

 

CardboxForumsCardbox Talk > "Search Issues"

Search Issues

Changes the Index options, but searching does not work unless I retype the names.

Current user: [none]
Register / Log In · Help

Posted By Post

Voices4Wellbeing

8-Sep-2011 08:34

We have had a problem searching our database. We have multiple fields for names, and so, for example, we searched for 'Joe Bloggs', or 'Joe', or 'Bloggs', and it would not find his record. If his name was in a different name field, it would.

I checked the settings and changed all the name fields index options to 'index all'.

It then started to work....for some records.

It still wouldn't find 'Joe Bloggs'. I went to Joe Bloggs record manually, and I edited this record. I deleted his name and retyped it in the same field. When I searched again, it found it.

Why did it not find it until I had edited the record? If this is the case it will cause major problems, because my searching will not work unless I edit nearly every record on my database.

I also have an issue searching for email addresses. I can search the email field for an email address with no problem, but it will not let me search 'all fields' for an email address because of illegal characters (the '@', I assume).

This is all making it very difficult to use our database.

Voices4Wellbeing

8-Sep-2011 09:00

I have worked out that I can do a data search and that will find it, but I would still be interested in knowing how to fix this issue.

bert

8-Sep-2011 09:20

After you changed field settings to "index all":
Did you use Cardbox menu option: Special- Management - Adjust Indexing?

And after using this option, problem solved?

Regards
Bert

Voices4Wellbeing

9-Sep-2011 10:43

The Adjust Indexing fixed the problem - thank you very much!

Quick Reply

Please log in or register before trying to post a reply.

 
© 2010 Cardbox Software Limited   Home