Home

Cardbox Talk

 

CardboxForumsCardbox Talk > "Line spacing when printing"

Line spacing when printing

Problem when printing data from a Cardbox file onto a pre-printed form

Current user: [none]
Register / Log In · Help

Posted By Post

John Francis

27-Jul-2010 13:55

I am trying to print data from a Cardbox database onto a pre-printed form (actually a card). The form has headings printed at approximately 6mm spacing, but the printed output from Cardbox has a 4mm spacing (approx). Does anyone know of a solution to this, or is it something I just have to live with?

bert

27-Jul-2010 17:44

Try to change the format font (edit format/edit/format properties/appearance) to a font size that is fitting for your form. Every font/size needs it's own line-height. Cardbox format changes line height to the used format appearance.

If that results in an unwanted printed font, change individual field layout to the font you want to print (double click on a field in edit format mode, appearance. The field appearance is dominant to format appearance.

If field appearance needs more room that there is on one line, it takes two or more format lines (if possible - on the first line of a format there is no more line height available than the format font offers...).

Playing with this features I am convinced you will find a solution. I did in many situations.

Regards
Bert

John Francis

28-Jul-2010 10:47

Oh dear, I didn't describe my problem clearly enough! I need to align the output from separate Cardbox fields with the headings on the pre-printed form. If I increase font size, I simply get the dreaded pink stripesindicating overlapping fields.
However, Bert's reply gives me an idea: perhaps I can write a macro to copy the output of the appropriate fields to a single field; that field's appearance (font size) can be set so that the lines are spaced as needed. I'll work on it.

bert

28-Jul-2010 11:38

Ok, I hope that your workaround will work.

However: Overlapping fields you get when FIELD appearance has a larger font then FORMAT appearance. That is no problem in many situations.

I your situation: First step is set all Fields to standard (format) appearance (notice the red dot in the field appearance dialog - it lights up when field appearances are set. When you click on it, the field is reset to format appearance).

Then choose as format appearance right font which has right line spacing.
When the font is not what you wish, change it to what you need.

An extreme solution:
I did one time change the FORMAT font to 2p high.
On the right positions (and in that situation you get every 2p a line which is more than enough, I placed mergeblocks *with their own font size*. The mergeblocks I could place exact where they has to be.

Of course, Cardbox screams when saving such a format. However, this is no problem.
It is a little puzzling, however, it is possible.

Success,
Bert

Charles Welling

28-Jul-2010 12:22

Francis, you could use a label type to solve your problem. Let's assume you have 5 headings.

Create a format and create a custom label type. Look in the help file if you're not familiar with how to do this. Define your label type as having 1 label across. You could set the left offset so that printing will start right of the headings. In this case you can place your fields in the format to the extreme left. Set the number of labels (= headings) to 5. Modify the printer settings under "Records" if so that more records per label are allowed (uncheck the "1 record per label" entry).

Label heights can be defined in mm. Use the minimum height needed for your font. Try 4 mm to start with. Cardbox will notify you if the size is too small.
Define the gap between labels as being 2 mm. This gives you a total of 6 mm. You can modify the size of this gap until you have the right value.

If you use this label type for printing, Cardbox will divide your card into 5 labels, each one having a height of 4 mm with an added gap of 2 mm, and print your fields accordingly.
Make sure that your fields are in merge blocks with a fixed height and that the first merge block starts on a new page to make sure that each record starts on a new card. You can check this option in the merge block properties.

Regards, Charles

Quick Reply

Please log in or register before trying to post a reply.

 
© 2010 Cardbox Software Limited   Home